metasploit在mac上怎么用

2019-08-13 14:21 来源:未知

  你可以直接使用brew来下载并自动安装postgresql,可以运行如下命令

  上面的步骤完成后,需更改metasploit的数据库连接配置,也就是第一步中的database.yml文件

  完成后,重新打开终端,输入ruby –version就可以看到当前默认的ruby版本已经设置成为1.9.3-p547

  (在bundle install的过程中,可能会出现某一个特定版本的模块安装失败的问题,解决方法:根据GemFiles里的版本限制,自行使用gem安装替代版本,完成后,删掉GemFiles.lock,重新运行bundle install)

  依赖解决后,即可运行目录下的msfconsole启动metasploit终端控制器(已启动postgresql,不然会连不上数据库)

TAG标签: msf数据库
版权声明:转载须经版权人书面授权并注明来源